SUPORTE TÉCNICO
De segunda à sexta pelo e-mail:
suporte@robocore.net
CENTRAL DE ATENDIMENTO
De segunda à sexta das 8:00 às 17:30
(11) 3522-7626 / vendas@robocore.net
Retornar
ao topo

Classifique este tópicoPéssimoRuimMedianoBomÓtimo
Autor
Mensagem

lucasgb7_ks

Level 0
45476 xp

Registrado em:
27/05/2021





Mensagens:
2

lucasgb7_ks

Responder com citações
Mensagem Qua Ago 25, 2021 9:29 pm
Erro na biblioteca RoboCore - SMW_SX1276M0
Boa noite, eu estou passando recentemente por problemas com a biblioteca RoboCore - SMW_SX1276M0 (RoboCore - SMW_SX1276M0) disponibilizada na extensão PlatformIO.

Meu projeto inclui a comunicação de um ESP32 DEVKIT V1 com o Módulo LoRaWAN Bee V2, porém não cheguei nem na parte dessa integração pois estou travado em tentar compilar o código. 

Quando eu executo o código de exemplo (SimpleJoin_OTAA_ESP32.ino) ocorrem vários erros que são da própria biblioteca fornecida, por exemplo:

Código:
Este erro é o mais comum, vários pontos em várias variáveis dão esse erro.

Já fiz uma busca na internet (resultado) que dizem para alterar a ordem da declaração de variáveis ou rodar com o -Wno-reorder (porém o PlatformIO não permite a execução desse comando).

Enfim, estou totalmente travado nessa parte e não encontro nenhuma documentação nem atualização da biblioteca para tratar disso.[/url]

Giovanni5

Level 3
3717789 xp

Registrado em:
15/12/2016



Equipe:
VagalBotzzzzz

Mensagens:
39

Giovanni5

Responder com citações
Mensagem Sex Ago 27, 2021 11:15 am
Erro na biblioteca RoboCore - SMW_SX1276M0
Bom dia lucasgb7_ks,

Você está utilizando a PlatformIO em qual editor de código? Você poderia nos encaminhar uma cópia completa da mensagem de erro retornada pela ferramenta ao tentar compilar o código de exemplo da biblioteca? Se a mensagem for muito extensa, você pode nos encaminhar ela em um arquivo de texto para o e-mail suporte@robocore.net. Com isso poderemos entender melhor os erros gerados, para uma atualização da biblioteca.

Nós testamos a biblioteca somente pela Arduino IDE, que é a ferramenta que normalmente usamos e recomendamos, então por isso alguns erros de compatibilidade com outras ferramentas podem acabar passando.

Como garantimos o funcionamento da biblioteca com a Arduino IDE, você pode seguir com o estudo do Kit por esta ferramenta, enquanto trabalhamos na atualização de compatibilidade com a PlatformIO.

lucasgb7_ks

Level 0
45476 xp

Registrado em:
27/05/2021





Mensagens:
2

lucasgb7_ks

Responder com citações
Mensagem Sab Ago 28, 2021 5:21 pm
Erro na biblioteca RoboCore - SMW_SX1276M0
Boa tarde Giovanni5,

Estou utilizando o PlatformIO no VSCode, estarei disponibilizando o log de erros:

https://prnt.sc/1qp3hg4

Eu consegui resolver este erro da seguinte forma:

Trocando a ordem da declaração das variáveis "_size" e "_index".
<Buffer.H> 68 ~ 72
Código:

Trocando a ordem da chamada da função "event_listener" em primeiro.
<RoboCore_SMW_SX1276M0.cpp> 51 ~ 63
Código:

A solução desse problema apenas descarta os erros, porém continuo com alguns warnings. Quando testei no ArduinoIDE com a biblioteca original não ocorreu nenhum erro felizmente, o problema está com a forma que o `PlaftomIO compila. Como eu encontrei a biblioteca na própria plataforma do PlatformIO, creio que poderiam fazer uma atualização apenas pra lá (se isso fosse possível).

De qualquer forma, agradeço o suporte Smile

Giovanni5

Level 3
3717789 xp

Registrado em:
15/12/2016



Equipe:
VagalBotzzzzz

Mensagens:
39

Giovanni5

Responder com citações
Mensagem Qua Set 01, 2021 12:36 pm
Erro na biblioteca RoboCore - SMW_SX1276M0
lucasgb7_ks,

Agradecemos pelas sugestões, iremos analisar a compatibilidade da biblioteca com a Pltaform IO e atualizá-la. Entretanto, como temos outros projetos em andamento, essa atualização pode demorar um pouco para ser disponibilizada. Como você aparentemente solucionou o problema (mesmo que parcialmente), você pode utilizar a biblioteca com as modificações que fez com a Platform IO, porém ainda recomendamos o uso da Arduino IDE, pois é a ferramenta que testamos e temos como garantir o funcionamento correto com o módulo, enquanto a atualização da biblioteca não for oficializada.
Mostrar mensagens desde a última:




Ir para:  
Todos os horários são GMT - 3 HorasVocê não tem permissão para escrever novas mensagens
v não tem permissão para responder às mensagens
Você não tem permissão para editar suas mensagens
Você não tem permissão para deletar suas mensagens
Você não tem permissão para classificar tópicos
Você não tem permissão para classificar mensagens
Você não tem permissão para votar em enquetes
Anexar downloads : Proibido
Fazer Download de Arquivos: Permitido
Powered by phpBB © 2001 phpBB Group