LOJA FÍSICA
Praça Mauá, 4541 - Sala 22
09580-050 - São Caetano do Sul / SP
CENTRAL DE ATENDIMENTO
(11) 3522-7626
info@robocore.net
HORÁRIO DE FUNCIONAMENTO
De segunda à sexta das 9:00 às 19:00
Sábado das 9:00 às 13:00
^ Retornar ao
topo
LCD 16x2 5V Preto no Verde

Quantidade:
Formas de pagamento:
Pague em até 12x no cartão
Pague através do PayPal
Pague por Boleto Bancário

Este é um display basico de 16 caracteres por 2 linhas. Texto preto sobre fundo verde. Utiliza o extremamente comum chipset HD44780 de interface paralela (datasheet). O código da interface está disponível gratuitamente. Você vai precisar de aproximadamente 11 pinos de entrada/saída (I/O) para fazer interface com esta tela LCD. Inclui LED backlight.


Obs: É necessário adquirir uma Barra de Pinos Macho e soldá-la no display LCD.
  • Display LCD 16x2 de alta qualidade
  • Dimensões: 3.15" x 1.425" x 0.350"
  • Tensão de alimentação: 5V


Para fazer comentários é necessário estar logado. Efetuar login.

Você ainda nao é cadastrado? Cadastre-se agora!



weynelucas
Enviado: 2016-03-19 16:08:43


Este display funciona com algum microcontrolador de 3.3V? No meu arduino funciona corretamente, mas estou testando em um TM4C123 (Tiva C Launchpad) e só o backlight acende. Estou perguntando porque você disse no comentário: "Ele funciona com qualquer microcontrolador", mas pelo datasheet do fabricante (LCDC 1602BYY - LC Eletrônica) parece que só funciona à 5V.

Datasheet do fabricante: http://www.lceletronica.com.br/datasheets/displays_graficos/display_caracteres/LCDC1602B.pdf

weynelucas
Enviado: 2016-03-19 16:44:43

O display funciona com um microcontrolador de 3.3V, mas a alimentação do display deve ser 5V!


kayosiqueira
Enviado: 2015-07-13 14:25:10


Vem com backlight e com conector já soldado?

ViniDj
Enviado: 2015-07-13 14:43:12

Vai com backlight, porém não vai com conector soldado.


MatheusFS
Enviado: 2014-11-07 14:22:56


Comprei este display nesta semana. Fiz a ligação e rodei o programa conforme instruído no site do Arduino, porem somente metade do display está "imprimindo" as informações. Gostaria de saber como devo proceder. Grato.

ViniDj
Enviado: 2014-11-07 15:28:55

Envie uma foto de como está ligando o display para info@robocore.net para verificarmos a ligação e também envie o arquivo .INO do programa que está usando no Arduino.

MatheusFS
Enviado: 2014-11-07 18:35:20

Encaminharei o mais breve possível. Agradeço a atenção!


Vando
Enviado: 2014-10-28 09:06:13


Enviei o e-mail conforme vocês pediram. Aguardo retorno. Grato.


Vando
Enviado: 2014-10-27 16:17:55


Comprei o kit iniciante algum tempo atras. Tentei de todas as formas possíveis mas não consigo fazer o lcd funcionar como deveria. Na tela só fica mostrando uns riscos em baixo e em cima, tentei acender o  backlight  nos pinos 16 e 15 e nada. Baixei a imagem com a correção das ligações para o lcd que veio no meu kit e mesmo assim nada funcionou.

ViniDj
Enviado: 2014-10-27 16:24:08

Por favor, envie um email para info@robocore.net com fotos em boa definição da montagem do circuito na protoboard, número do pedido do kit iniciante (ORDER ID) e explicação do problema. Iremos lhe auxiliar no que for preciso e caso o LCD esteja com defeito, iremos fazer a troca.


sandropereira34
Enviado: 2014-08-19 11:12:34


Eu comprei um kit iniciante, gostei muito dos projetos, pra mim que sou leigo com Arduino estou fascinado quero seguir com outro kits parabéns a equipe , mais os projetos com LCD não consegui fazer o meu fica todo aceso e não aparece os quadrados escuro, na loja não vejo outro parecido com o meu , pois o meu mostra ser nacional Mod. LCDC 1602BYY ajuda por favor não consegui no fórun . 

ViniDj
Enviado: 2014-08-20 18:53:51

Por favor, envie a descrição do seu problema e fotos do projeto para info@robocore.net para que possamos lhe auxiliar.


yago4xd
Enviado: 2014-07-31 00:26:30


Boa noite, gostaria de saber quais pinos são referentes ao SDA e o SCL. O display que uso é o que veio no kit iniciante v6.1! Preciso ligar esses pinos no A4 e A5 respectivamente no arduino para esse projeto: "http://arduinobymyself.blogspot.com.br/2012/03/arduino-sistema-de-seguranca-controle.html". Nesse caso, liguei o pino 1 no GND e o 2 no 5V (observando a pinagem na vista superior do lcd e considerando o 1º pelo lado esquerdo e o último como o pino maior, pino 17). Caso não tenha esses pinos, tenho um lcd keypad shield.. Quais seriam os pinos nesse, caso no outro não seja possível? Obrigado!

ViniDj
Enviado: 2014-07-31 11:57:18

Este shield é serial, para utilizá-lo você precisa ligar diversos pinos conforme o kit iniciante. Este lcd não possui a interface digital para uso com o SDA e SCL. 

yago4xd
Enviado: 2014-07-31 12:33:31

No caso do shield, como faria? Tem esses pinos? Obrigado!

ViniDj
Enviado: 2014-07-31 13:11:56

Para você usar o LCD com 2 pinos ele precisa ser preparado para isso. Este LCD e o que vem no kit iniciante são seriais, não são preparados para isso. Se o shield tiver a interface serial-digital você consegue usar, se não, não.

yago4xd
Enviado: 2014-07-31 15:27:53

Hum.. Certo, o shield que tenho é desse modelo: http://www.aliexpress.com/snapshot/6051837835.html

Francois
Enviado: 2014-08-02 14:46:24

O shield do link que enviou NÃO trabalha com o protocolo I2C (SDA e SCL).


joao.vitor
Enviado: 2014-02-24 22:22:50


Boa noite,
Estou tendo o mesmo problema relatado por oscardalferth, onde o LCD fica muito escuro. Tentei a solução proposta, de ligar os pinos 15 e 16, porém o backlight acende, mas as letras não aparecem.
Alguma sugestão?

ViniDj
Enviado: 2014-02-25 07:30:14

Seu problema deve ser algum fio errado, o que faz com que não apareça nenhum caracter. Você girou o eixo do potenciometro totalmente pros dois lados para ver se o problema não é o contraste?


evandro007
Enviado: 2014-02-16 21:07:00


o LCD q vem no kit iniciante, é o msm que esse aqui? se  não poderia me informar o modelo do que vem no kit?

Francois
Enviado: 2014-02-17 14:15:56

Atualmente o Kit Iniciante está indo com o LCD Laranja no Preto: http://www.robocore.net/modules.php?name=GR_LojaVirtual&prod=127.


AllanLemos
Enviado: 2013-12-18 14:09:35


Vem com o conector?

ViniDj
Enviado: 2013-12-18 14:27:12

Não vai com conector, você precisa adquirir separadamente. Se você for ligar na protoboard, sugerimos comprar uma barra de pinos macho. Se você vai ligar diretamente com jumpers, sugerimos comprar uma barra de pinos fêmea. Não enviamos com conector pois cada um usa de uma forma.


gscolle
Enviado: 2013-12-17 12:41:47


Resolvido! O meu é o que vem no kit, obrigado pela ajuda.


gscolle
Enviado: 2013-12-17 12:01:40


Bom dia, logo quando energizo o pino 1,2e3 ele acende o backlight, como posso fazer para desliga-lo e deixar apenas as letras?

ViniDj
Enviado: 2013-12-17 12:05:12

Os pinos 15 e 16 são responsáveis pelo backlight (últimos pinos da direita). Se não ligar estes pinos, o backlight não liga.

gscolle
Enviado: 2013-12-17 12:37:29

talvez eu precise mudar alguma ligação atras do lcd? pois meu backlight liga sem estar com esses pinos ligados

ViniDj
Enviado: 2013-12-17 12:38:27

Seu LCD é exatamente este ou é o que vai no kit iniciante? Pois o que vai no kit iniciante não é este modelo, o do kit é um LCD que não pode ter seu backlight desligado. 


oscardalferth
Enviado: 2013-12-12 13:39:21


Boa tarde, fiz o esquema do LCD ao arduino, porem o contraste nao fico legal, fica muito escuro, quase nao da para visualizar nada, ja revisei as ligaçoes, porem nao acho a causa, no restante ele funciona normalmente, as escritas e etc, somente o contraste nao fico bacana. Alguma dica?

ViniDj
Enviado: 2013-12-12 13:42:36

Você ligou o backlight?

oscardalferth
Enviado: 2013-12-12 14:13:37

qual os pinos?

ViniDj
Enviado: 2013-12-12 14:18:18

Os dois últimos da direita, o 15 e 16. Basta colocar 5V e GND, nesta ordem, e o LED do backlight acenderá. 

oscardalferth
Enviado: 2013-12-12 14:21:13

Muito Obrigado!


ghangster
Enviado: 2013-12-02 21:38:06


Boa noite equipe.
Estou conectando meu LCD ao arduino seguindo os passos da apostila que vem junto ao kit, porém quando inicio o programa o lcd fica com a primeira linha toda quadriculada e na segunda linha vazia. 
Alguém podería me ajudar?


Niposan
Enviado: 2013-12-03 10:27:42

pode ser alguma conexão errada ou o ajuste do contraste através do potenciômetro.


daflon
Enviado: 2012-08-17 12:00:08


Funciona com PIC? obrigado.

ViniDj
Enviado: 2012-08-17 12:06:48

Ele funciona com qualquer microcontrolador, inclusive PIC.


Mimos
Enviado: 2011-08-20 14:03:52


bonitin!!!