Fórum


Classifique este tópicoPéssimoRuimMedianoBomÓtimo
Autor
Mensagem

matheus.markies

Level 0
0 xp

Registrado em:
17/10/2022





Mensagens:
1

matheus.markies

Responder com citações
Mensagem Seg Out 17, 2022 12:34 pm
Multiplexador TCA9548A + TCS34725 e Arduino Mega
Estou tentando usar o arduino mega com um Multiplexador TCA9548A e dois sensores de cores, mas não estou conseguindo conectar o arduino com os dois sensores.
Quando tento escanear o TCA9548A ele retorna que não existem I2Cs conectados.

Código do escaner 

Código:


Saida:
Thumbnail, clique para aumentar.
Os primeiros logs são de quando eu conectei o sensor de cor direto no arduino, depois eu utilizei o TCA9548 e carreguei o código de novo, e resultou nesses logs em que nenhum sensor foi identificado. Minha configuração:
Thumbnail, clique para aumentar.
Thumbnail, clique para aumentar.
Thumbnail, clique para aumentar.
Vermelho -> SDAs dos sensores. Laranja -> SCLs dos sensores. O cabo roxo vai para o Arduino SDA e o cabo azul vai para o Arduino SCL. Quando conecto os sensores diretamente no arduino eles funcionam normalmente. Em resumo, estou tendo problemas para usar os dois sensores de cor em conjunto com o multiplexador e não sei onde esta o problema. Será que o multiplexador pode estar com mal funcionamento ? ou minha montagem possui algum erro ?
Mostrar mensagens desde a última:




Ir para:  
Todos os horários são GMT - 3 HorasVocê não tem permissão para escrever novas mensagens
v não tem permissão para responder às mensagens
Você não tem permissão para editar suas mensagens
Você não tem permissão para deletar suas mensagens
Você não tem permissão para classificar tópicos
Você não tem permissão para classificar mensagens
Você não tem permissão para votar em enquetes
Anexar downloads : Proibido
Fazer Download de Arquivos: Proibido
Powered by phpBB © 2001 phpBB Group