Fórum


Classifique este tópicoPéssimoRuimMedianoBomÓtimo
Autor
Mensagem

lubebeu

Level 0
2000 xp

Registrado em:
20/09/2021





Mensagens:
1

lubebeu

Responder com citações
Mensagem Qui Out 07, 2021 5:06 pm
Erro na hora de enviar o código para a Blackboard UNO R3
Comprei recentemente o Kit iniciante V8. E por conta do curso da minha faculdade, eu já sei varias coisas relacionadas a arduino. Antes de fazer esse projeto, tudo funcionava perfeitamente.

Eu estava fazendo um projeto da faculdade e após fazer todas as conexões (são várias), coloquei sem querer um LED conectado na parte de corrente positiva da protoboard (ao invés do negativo) e o outro lado (com resistor) na porta digital. Ao ligar o Arduino no computador e, passar o código para ele,  ele ligava o LCD e o resto do circuito, e logo em seguida ele desligava o LCD (não sei dizer se o resto desligava também), mas o sensor LDR e o LED (o que estava conectado errado) continuavam funcionando normalmente.
Depois de eu perceber que fiz essa conexão do LED errada, a arrumei. E também mudei as portas que eu estava utilizando nesse LED e em um outro, pois eu estava achando que estava dando esses bugs por conta dessas entradas (0 e 1) que estavam sendo usadas por eles (ps: eu já tinha tirado o Serial.begin do codigo).

Logo após isso, meu Arduino não está recebendo nenhum código da IDE, ele fica carregando por muito tempo e depois dá um erro.
Não escutei nenhum barulho de estouro, o arduino continua ligando normalmente, e tambem é reconhecido pelo computador e pela IDE. Pelo que me parece ele chegou a apagar o codigo anterior, mas não recebe mais nenhum.

Já pesquisei um pouco e tentei várias coisas, como:
* desinstalei e instalei a IDE do arduino
* apaguei e reinstalei o driver do arduino no computador
* verifiquei se o código estava sendo enviado para a COM certa,...
* Testei em vários outros códigos
* Não é o cabo

Testei fazer um loop loopback tx-rx e ele executa isso normal.

Alguns erros que estão dando:

Quando eu tento enviar o codigo pela primeira vez ao abrir a IDE. Ele pisca o RX algumas vezes enquanto esta conectado.
(aqui demora bastante para aparecer esse erro):

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x28

Quando eu clico para tentar enviar novamente, sem fechar a IDE ou desconectar o arduino:

Ocorreu um erro enquanto o sketch era carregado

Se eu tento abrir a porta serial (sem estar com o loopback tx-rx ligado):

Erro ao abrir porta serial "COM5". (Port busy)

Francois

Level 2
2966374 xp

Registrado em:
08/04/2013



Equipe:
RC Teste

Mensagens:
75

Francois

Responder com citações
Mensagem Sex Out 08, 2021 11:15 am
Erro na hora de enviar o código para a Blackboard UNO R3
@lubebeu, pode acontecer do circuito deixar de funcionar mesmo sem ter danos visíveis. Claro, esse tipo de dano pode deixar mais claro onde está o problema, porém nem sempre acontece.

Como uma boa parte do circuito está funcional, talvez seja apenas a falta do bootloader na placa. Se você tiver acesso a outra placa Arduino, você pode tentar regravar o bootloader na sua placa seguindo o passo a passo do tutorial a seguir: https://www.robocore.net/...ader-no-arduino.

Você também pode verificar como a placa está sendo reconhecida no seu computador (algo como o "Gerenciador de Dispositivos" do seu sistema operacional) e se ela funciona em outro computador. Como você comentou da porta estar ocupada, isso significa que outro processo está a acessando. Além disso, se você possuir um multímetro, você pode confirmar que as saídas "5V" e "3V3" estão, respectivamente, com 5 e 3,3 V.
Mostrar mensagens desde a última:




Ir para:  
Todos os horários são GMT - 3 HorasVocê não tem permissão para escrever novas mensagens
v não tem permissão para responder às mensagens
Você não tem permissão para editar suas mensagens
Você não tem permissão para deletar suas mensagens
Você não tem permissão para classificar tópicos
Você não tem permissão para classificar mensagens
Você não tem permissão para votar em enquetes
Anexar downloads : Proibido
Fazer Download de Arquivos: Permitido
Powered by phpBB © 2001 phpBB Group