CENTRAL DE ATENDIMENTO
De segunda à sexta das 8:00 às 17:30
(11) 3522-7626 / vendas@robocore.net
Retornar
ao topo

Classifique este tópicoPéssimoRuimMedianoBomÓtimo
Autor
Mensagem
3
hgraner

Level 0
100977 xp

Registrado em:
20/10/2013





Mensagens:
1
3
hgraner

Responder com citações
Mensagem Sab Jul 13, 2019 12:14 am
ROBO usando controle de motor pela L298N
Fiz um robo maneiro, modelo básico usando sensor ultrasom, e uma L298N para controlar os motores!

Coloquei uma velocidade baixa mas quando encontro pequenos obstáculos (um tapete por exemplo), o robo trava (imagino que por conta da baixa tensão aplicado aos motores). 

Se eu conseguisse fazer ele reconhecer a variação da tensão que ocorre nos motores quando eles travam, seria ótimo! Mas obviamente estamos falando de um PWM e a leitura feita pela Arduino UNO fica variando, tornando impossível uma leitura estável do estado dos motores entre andando e travado. A entrada analógica A5 (utilizada por mim) faz leitura entra 0 e 1023. Tentei colocar capacitor 100N em paralelo com o sinal para tentar retificar e nao serviu de nada.

Alguma ideia???

Henrique GM.
Mostrar mensagens desde a última:




Ir para:  
Todos os horários são GMT - 3 HorasVocê não tem permissão para escrever novas mensagens
v não tem permissão para responder às mensagens
Você não tem permissão para editar suas mensagens
Você não tem permissão para deletar suas mensagens
Você não tem permissão para classificar tópicos
Você não tem permissão para classificar mensagens
Você não tem permissão para votar em enquetes
Anexar downloads : Proibido
Fazer Download de Arquivos: Proibido
Powered by phpBB © 2001 phpBB Group