LOJA FÍSICA
Praça Mauá, 4541 - Sala 22
09580-050 - São Caetano do Sul / SP
CENTRAL DE ATENDIMENTO
(11) 3522-7626
info@robocore.net
HORÁRIO DE FUNCIONAMENTO
De segunda à sexta das 9:00 às 19:00
Retornar
ao topo

ESP32 - WiFi & Bluetooth


Quantidade:
Formas de pagamento:
  • Pague em até 12x no cartão
  • Pague através do PayPal
  • Pague por Boleto Bancário

Precisando de mais poder de processamento e mais recursos do que o NodeMCU pode fornecer? Este é o módulo certo para você! O módulo ESP32 traz consigo o microprocessador Xtensa® Dual-Core 32-bit LX6, com um clock máximo de 240MHz, memória RAM de 520 KBytes e Flash de 4MB. Além das consagradas funções de conexão WiFi, esta placa traz ainda conectividade via Bluetooth Low Energy (BLE), no padrão 4.2.

Este módulo chega no mercado para trazer ainda mais performance e poder de processamento para aplicações de Internet das Coisas, automação residencial, prototipagem com comunicação sem fio e muito mais. Com seu baixo consumo de energia é uma ferramenta essencial para qualquer desenvolvedor.

Veja abaixo as informações técnicas desse módulo:
  • Processador: Xtensa® Dual-Core 32-bit LX6
  • Memória Flash programável: 4MB
  • Memória RAM: 520KBytes
  • Memória ROM: 448KBytes
  • Clock máximo: 240MHz
  • Pinos Digitais GPIO: 11 (todos com PWM)
  • Resolução do PWM: até 16 bits (ajustável via código)
  • Wireless 802.11 b/g/n - 2.4GHz (antena integrada)
  • Modos de operação: Access Point / Estação / Access Point + Estação
  • Bluetooth Low Energy padrão 4.2 integrado
  • Tensão de alimentação externa: 4,5V a 9V (módulo possui regulador integrado para 3,3V)
Assim como o NodeMCU, esta placa também pode ser programada em LUA ou pela IDE do Arduino.
Para programar utilizando a IDE do Arduino, clique aqui e siga as instruções para seu sistema operacional (conteúdo em inglês). Após efetuar todo procedimento, durante a gravação na IDE do Arduino aparecerá no console:

Connecting........_____....._____....._____....._____

Neste momento, pressione e mantenha pressionado o botão BOOT na placa para que ela comece a ser gravada, então solte o botão. Caso queira testar o LED da placa, grave o seguinte código:

void setup() {
  pinMode(2, OUTPUT);
}

void loop() {
  digitalWrite(2, HIGH);
  delay(500);
  digitalWrite(2, LOW);
  delay(500);
}

Para gravar códigos na placa é aconselhável utilizar um Cabo USB - Micro B (vendido separadamente).

Documentação:


Para fazer comentários é necessário estar logado. Efetuar login.

Você ainda nao é cadastrado? Cadastre-se agora!


p.h.art
date Enviado: 2018-04-29 16:46:39
to testando o SimpleWerbServerWifi mas da um erro:

'class WiFiClass' has no member named 'firmwareVersion'

alguém pra ajudar ? rs

ViniDj
date Enviado: 2018-04-30 09:44:19
p.h.art
O exemplo SimpleWebServerWiFi que você está tentando utilizar não é um código compatível com ESP32. Este código é compatível apenas com o Shield WiFi desenvolvido pela marca Arduino. Os códigos que são compatíveis com ESP32 estão nos menus de exemplos com o nome ESP32. ESP32 BLE Arduino, ESPmDNS encontrados em Arduino > Exemplos. Caso queira um exemplo de webserver para tomar como base, sugiro usar o código mDNS_Web_Server encontrado no menu Arduino > Exemplos > ESPmDNS.

p.h.art
date Enviado: 2018-05-01 01:57:29
p.h.art
Show amigo deu certo..é que tinha um tutorial e tal aqui na net e o cara dava esse caminho "simplewebserver"...mas resolvido conectado consegui visualizar pelo monitor serial vlw mesmo

p.h.art
date Enviado: 2018-04-17 20:40:29
Boa noite to com um problema e uma esp32 miinha que e o seguinte erro

'LED_BUILTIN' was not declared in this scope"

acabei de instalar os programas e tal pra programar pelo arduino mas quando vou fazer um blink da esse erro

hallszombie
date Enviado: 2018-04-18 07:43:12
p.h.art
Este erro é referente a variável LED_BUILTIN, verifique se o mesmo foi declarado no código.

p.h.art
date Enviado: 2018-04-18 13:53:47
p.h.art
é eu vi que meu problema e muito maior minha placa e esp wroom 32 , depois de fazer as configurações corretas adicionando no arduino a placa e tal baixando o programa etc..a placa continua nao conectando nem teste de led nada..creio que o problema seja na placa mesmo

ViniDj
date Enviado: 2018-04-18 13:57:35
p.h.art
Tome cuidado, essa placa não trabalha com os códigos de teste que possuem o LED_BUILTIN. Pra saber se a placa está funcionando, grave o seguinte código nela:

void setup() {
  pinMode(2, OUTPUT);
}

void loop() {
  digitalWrite(2, HIGH);
  delay(500);
  digitalWrite(2, LOW);
  delay(500);
}

p.h.art
date Enviado: 2018-04-18 14:01:15
p.h.art
Ja havia testado com essa linha de codigo mas da o mesmo erro


"A fatal error occurred: Failed to connect to ESP32: Timed out waiting for packet header"

e algo com a conexao da placa mesmo creio..

ViniDj
date Enviado: 2018-04-18 14:03:52
p.h.art
Quando apareceu a mensagem Connecting........_____....._____....._____....._____ você segurou apertado o botão BOOT na placa?

p.h.art
date Enviado: 2018-04-18 14:11:11
p.h.art
Sim e continua dando erro eu estou selecionando a placa

ESP32 DV MODULE -  80MHZ - 4MB -  VELOCIDADE 921600 - NONE EM COM1

Será que tem algo nessa parte de errado?

Minha placa e ESP WROOM 32

ViniDj
date Enviado: 2018-04-18 14:17:32
p.h.art
Existe alguma outra porta COM disponível em Ferramentas > Porta?

p.h.art
date Enviado: 2018-04-18 14:26:32
p.h.art
Existe só a com1 mesmo vou te explicar o processo que fiz, pra vc estar a parte 

a placa ta na proto board..ok ligada no usb normal..led vermelho ligado blz
ai eu baixei o python2.7 instalei depois o Git...depois clonei a pasta la pra c:documentos/arduino....e tal.. e ai
após fazer isso apareceu no programa arduino certinho la a placa ESP32 DEV MODULE e várias outras placa da familia esp32

a partir dai deu erro varias vezes esse erro de conectando... e ai nao conecta.. 

Mas tem 2 pontos interessantes, a placa no pc ela fica dando aquele som de conectando e desconectando no windows..algumas vezes, ..depois para.

e o dispositivo nao esta reconhecendo até instalei o programa 
"CP210x USB to UART Bridge VCP Drivers" e mesmo instalado nao reconheceu...

por um momento..apareceu lá alem nas portas COM disponiveis a porta COM4 mas ai sumiu depois.

Estou realmente confuso

ViniDj
date Enviado: 2018-04-18 14:34:43
p.h.art
Geralmente COM1 não é a porta da placa e sim uma reservada do sistema, então provavelmente esse é o problema. Sugiro testar com outro cabo e em outra porta USB. Se o driver da Siliconlabs foi instalado corretamente, deve aparecer uma nova porta ao conectar a placa.

p.h.art
date Enviado: 2018-04-18 14:49:51
p.h.art
haha consegui..finalmente rs depois de ir la no gerenciador de dispositivos, reinstalar o siliconlabs e trocar o cabo e a porta deu certo Led piscando hha it's alive!!! engraçado q comprei um cabo novo pra isso mas o cabo antigo q deu conta rsrs apareceu la a COM4 depois de reinstalar e tal...Muito obrigado pela ajuda haha unico lugar aonde achei alguem pra ajudar..rsrs vlw mesmo

snorlax
date Enviado: 2018-04-10 23:24:51
Boa Noite! Ele já vem com os pinos soldados? Obrigado!

ViniDj
date Enviado: 2018-04-11 06:16:40
snorlax
Ele é enviado exatamente como na foto, ou seja, com os pinos soldados.